Home > Could Not > Internal Error Could Not Perform Immediate Configuration 2 On Debconf

Internal Error Could Not Perform Immediate Configuration 2 On Debconf

Contents

More information can be found in the Debian Linux Kernel Handbook, which can also be found as the debian-kernel-handbook package. Upgrading your kernel and related packages4.6.1. Things to do before rebooting4.8. Done Building dependency tree Reading state information... http://mttags.com/could-not/internal-error-could-not-perform-immediate-configuration-1-on-debconf.php

That chapter covers potential issues which are not directly related to the upgrade process but could still be important to know about before you begin. 4.1.1. Back up any data or configuration Thanks, Udo Update: running [email protected]:~# aptitude full-upgrade No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 0B of archives. Linked 3 packages been kept back 1 do-release-upgrade hangs at downloading openjdk-6-jre-headless Related 3“Could not determine the upgrade” while trying to update from 10.10 to 11.041Upgrading kubuntu to version 12.10 stops1I http://superuser.com/questions/199582/apt-error-could-not-perform-immediate-configuration-on

Please See Man 5 Apt.conf Under Apt::immediate-configure For Details. (2)

Detecting which packages in an updated system are “obsolete” is easy since the package management front-ends will mark them as such. Thanks for taking the time! –louisa Jul 20 '13 at 1:18 Edited. Unofficial sources4.3.

  • This is done by executing: # apt-get update 4.4.3. Make sure you have sufficient space for the upgrade You have to make sure before upgrading your system that you will have sufficient
  • Do you want to continue [Y/n]?
  • Need to get 0 B/9,304 kB of archives.
  • How to change log levels for apex tests I beat the wall of flesh but the jungle didn't grow restless Can a GM prohibit players from using external reference materials (like
  • Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the

Which Sitecore fields can be rendered using a FieldRenderer Are non-english speakers better protected from (international) Phishing? Install the kernel sources, provided in the linux-source package. You can either install one of the linux-image-* packages provided by Debian, or compile a customized kernel from source. Upgrade Debian 6 To 7 It said Could not perform immediate configuration on 'linux-headers-2.6-amd64.

To verify it works, insert a CD and try running # mount /media/cdrom # this will mount the CD to the mount point # ls -alF /media/cdrom # this should show Couldn't Configure Pre-depend Multiarch-support For Libnih-dbus1, Probably A Dependency Cycle. Hello, Everything works well when executing: Code: sudo apt-get update sudo apt-get upgrade When executing sudo apt-get dist-upgrade I get this Code: [email protected]:~# sudo apt-get dist-upgrade Reading package lists... Do not put the typescript file in a temporary directory such as /tmp or /var/tmp (files in those directories may be deleted during the upgrade or during any restart). https://ubuntuforums.org/showthread.php?t=1595928 Conclusion: just had to manage the dependencies by hand a bit to get it to work.

If you're not sure what to do, write down the name of the package or file and sort things out at a later time. This can be resolved by either using aptitude to choose these packages for installation or by trying apt-get install package. 4.5. Possible issues during upgrade The following sections describe known issues Installing a kernel metapackage4.6.2. Need to get 0B/49.7MB of archives.

Couldn't Configure Pre-depend Multiarch-support For Libnih-dbus1, Probably A Dependency Cycle.

Note: I also thought to reinstall apt. http://askubuntu.com/questions/244173/how-to-install-apps-when-apt-says-could-not-perform-immediate-configuration This requires that sysvinit is still installed and the binary /lib/sysvinit/init is included in your initramfs. Please See Man 5 Apt.conf Under Apt::immediate-configure For Details. (2) Preparing sources for APT4.3.1. Could Not Perform Immediate Configuration On 'passwd' How to avoid Johnson noise in high input impedance amplifier What could make an area of land be accessible only at certain times of the year?

Working without compensation, what to do? click site Thanks, Udo Adv Reply October 16th, 2010 #2 udito View Profile View Forum Posts Private Message 5 Cups of Ubuntu Join Date Dec 2008 Location Switzerland Beans 19 DistroUbuntu 10.10 Specific word to describe someone who is so good that isn't even considered in say a classification Is it ok to turn down a promotion? When you are asked if any file in the /etc/init.d directory, or the /etc/manpath.config file should be replaced by the package maintainer's version, it's usually necessary to answer “yes” to ensure Libasound2: Breaks: Libasound2-plugins (< 1.0.24) But 1.0.22-0ubuntu6 Is To Be Installed

their contents, sizes, and descriptions) before you remove them. more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science Function creating function, compiled languages equivalent Were students "forced to recite 'Allah is the only God'" in Tennessee public schools? news asked 4 years ago viewed 7398 times active 4 years ago Blog Stack Overflow Podcast #91 - Can You Stump Nick Craver?

How to know if a meal was cooked with or contains alcohol? During this time, these services will not be available. However, some applications (e.g.

Flour shortage in baking A secretary with ____ good knowledge of English: "a" or no article?

However, going to /var/cache/apt/archives and running dpkg -i --force-depends linux-headers-amd64_3.2+46_amd64.deb finally solved this problem. The upgrade process itself does not modify anything in the /home directory. Obsolete packages4.10.1. share|improve this answer answered Jul 8 at 7:29 Rene Brakus 1436 add a comment| up vote -1 down vote I had this problem on debian squeeze amd64 when upgrading to wheezy.

We have detailed known issues in Section 5.6, “Upgrading installs the new default init system for Jessie”. 4.5.7.2. LXC If you have LXC installed, you may need special care when upgrading your system If you have used aptitude or apt-get to manually install packages in wheezy it will have kept track of those packages you manually installed, and will be able to mark as Do not blindly remove the packages these tools present, especially if you are using aggressive non-default options that are prone to false positives. More about the author share|improve this answer answered Dec 29 '13 at 17:05 Jaimin pandya 589 add a comment| up vote 0 down vote When this error shows up: E: Internal Error, No file name

Recruiter wants me to take a loss upon hire Flour shortage in baking How to add line separators between columns in Latex table? Y E: Could not perform immediate configuration on 'libbz2-1.0'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2) Unfortunately I don't have a clue where the problem is... If you do manage to fix the problem, typing exit will quit the debug shell and continue the boot process at the point it failed. It said Could not perform immediate configuration on 'linux-headers-2.6-amd64.

Ask Ubuntu works best with JavaScript enabled UbuntuCommunityAsk!DeveloperDesignDiscourseHardwareInsightsJujuShopMore ›AppsHelpForumLaunchpadMAASCanonical current community chat Ask Ubuntu Ask Ubuntu Meta your communities Sign up or log in to customize your list. You can disable this by putting the following lines in /etc/e2fsck.conf: [options] broken_system_clock=1 4.7. Things to do before rebooting When apt-get dist-upgrade has finished, the “formal” upgrade is complete, but there are In car driving, why does wheel slipping cause loss of control? Do a minimal upgrade of the system (see Section 4.4.4, “Minimal system upgrade”) or partial upgrades of the system followed by a full upgrade.

The time now is 01:37 AM. results in the same error... dpkg: error processing multiarch-support (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: libc6 12.04 share|improve this question edited Jul 20 '13 at 1:34 asked Jul 20 '13 at Please install the package ruby to automatically track the current ruby version.

Please see man 5 apt.conf under APT::Immediate-Configure for details. If you do not have enough space for the upgrade, apt-get will warn you with a message like this: E: You don't have enough free space in /var/cache/apt/archives/. share|improve this answer answered Oct 7 '12 at 19:56 Albert 349617 Don't forget to accept your own answer after 2 days. –hexafraction Oct 7 '12 at 20:02 add a more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science

Special care for specific packages4.6. Use a temporary /var/cache/apt/archives: You can use a temporary cache directory from another filesystem (USB storage device, temporary hard disk, filesystem already in use, ...) Note Do not use an NFS